Waiting for emulator to start...

  • Hi! 👋

    I’m new to Quasar and Cordova (really, I decided to learn Quasar because I wanted to use cordova and Quasar seemed to be the best tool kit for me out there). So all of the steps I followed are coming from the documentation.

    After using some basic Vue functionalities around layouts, pages, and the router, I followed the mobile app preparation from top to bottom (it took awhile to download all of the sdk tools, android versions etc…).

    Building the cordova dev files, after running quasar dev -m cordova -T android, was all cool but when it came to deploying to emulator, my terminal is stuck at

    47 actionable tasks: 4 executed, 43 up-to-date
    Built the following apk(s):
    JAVA_HOME=C:\Program Files\Java\jdk1.8.0_181
    No target specified and no devices found, deploying to emulator
    No emulator specified, defaulting to Nexus_5X_API_28_x86
    Waiting for emulator to start...

    I was wondering if anyone has encountered this and how you solved this.

  • Those emulators can be VERY flaky beasts and if you get one working, I suggest sticking with it. BTW those are not part of and have nothing to do with Quasar per se. That is all Android SDK stuff so if we can’t help, maybe an Android forum or something like StackOverflow can. You should use a real device if you can though - it’ll save your hours (or days) in the long run. If not some things I have seen cause this or help fix it are:

    • Make sure the emulator being tried is installed. If you don’t see it in the SDK Manager, it is never going to run from CMD line

    • Assuming that emulator is there and runs in the SDK…

    • From the src-cordova\platforms\android folder listed in your error, try running ‘cordova run android’

    • It that works, then try your app again with it running it another window

    • Make sure the device is not already running in the AVD Manager. If it is turn the emulated device off by holding the On/Off button until android asks for “Power off”. After the shutdown try the app again

    • Be patient (if you haven’t already). I have seen some emulators take up to 5 minutes to load on some systems

    • If all that fails, your best bet as I said is to use a real device if you can… it’s save you tons of time

  • Same problem here… minutes before it was working and now it’s not!

    Did you find a solution @matteoo7?

  • Hi, if your emulator is still open this may not working. Try to turn it of before using the quasar dev command.

    If you get the waiting for emulator to start message, you can try to change to quick boot or cold boot. It solved the problem for me.

  • Well, somehow I managed to make quasar work with the emulator… maybe removing and recreating the avd did the trick… maybe reinstalling cordova package…
    Anyway the emulator still doesn’t start automatically but it’s just a small annoyance.

    For the sake of completeness I found this issue on cordova github: https://github.com/apache/cordova-android/issues/698
    We are not alone… 😛

Log in to reply