[0.17.5] HMR not working



  • Got this in the console when I save any file

    [WDS] App updated. Recompiling...
    [WDS] App hot update...
    

    but I still need to refresh (F5) to get the modification.

    and no significant errors 😞



  • I had the same problem with the 0.17.10… I tried to upgrade to 0.17.12 and still not working like you @ouaR … What is really strange is that it was working before for me and for some reasons (i don’t know yet) it stopped …



  • I don’t know if you are in the same situation but I recently “globalized” my node_modules directory (my quasar apps have now a symbolic link to a global node_modules dir) and HMR was not working anymore.

    but I found a solution, I updated my quasar.conf.js with :

    build: {
       // ........
       extendWebpack (cfg) {
          cfg.resolve.symlinks = true   // add this line
       }
    }
    

    and it works !



  • For my part, I had to remove the node_modules folder (previously init with yarn) and reinstall it but this time with npm.
    Then it worked for me again…