[Solved] Cordova App Displays Blank Page



  • Good day. I’ve started testing out Cordova in Quasar and can’t figure out since yesterday what might caused to display a blank page when app is run on the emulator. I haven’t tried installing the app on a real device since I don’t have one currently. I’ve carefully read the instructions on the Developing Mobile Apps section of Quasar Framework site and researched for similar problems but to no avail. The app is working when deployed on Web and as an Electron app though. This is the result of my trials:

    0_1527241619373_Screenshot_20180525_173752.png

    1_1527241619387_Screenshot_20180525_174215.png



  • Solved. It seems that the problem is on the version of the Android OS I’m using in the emulator. Currently I’m using Android 4.4 (Kitkat) and when I tried using Android 5 (Lollipop) as suggested by Razvan because Android less than 5 seems to use old web view, it worked. XD



  • I know this thread is old but this behavior is still present and I am facing it also.

    Nevertheless is there any chance to make quasar work on android 4.4?

    My problem is that I have an app that people want to run on their spare old tablets which are mostly running Android 4.4.



  • @Alvsky check if cordova still support 4.4, it’s not a quasar issue.



  • Thanks for the reply.
    My aim was not to imply whos issue is that but to see if someone had same experience and how it was solved.

    I did some more digging and ran into a cordova-plugin-crosswalk-webview-v3
    But the drawback is tha it adds about 17MB to the apk which is too much.

    So if someone had this kind of problem and has solved it some other way it would be helpful


Log in to reply