[Solved] First Quasar Android app - Nexus 7 too slow? Button presses massively delayed - leads to double-pressing.



  • Hello all,

    I wrote a very simple application. In the left side tray is a tree which holds a menu. There is a header, a main page, and a footer.

    The menu is used to figure out which page ID to use in an axios REST request. The result is displayed in the main page. The header just has a logo and button to open the side tray. The footer has next/prev icon buttons.

    The tray opens and closes quickly. The menu scrolls quickly as does the main page content.

    What is weird is that the next/prev buttons seem to take half a second or more to before the pulse animation begins and the application then responds. Likewise with each of the tree elements. The delay on the menu is long enough that one is inclined to press it a second time, thinking that the first one didn’t work. This, of course, closes that level which you just tried to open. Issue exists with both dev and release versions.

    Before I post code, has anyone seen something like this? Is the Nexus 7 old enough that it is simply too slow for this? Are there build settings not stipulated in the tutorial that could help? I’ve built Android apps before in Android Studio. Perhaps I should open it there and compile from there? I’m using quasar-cli 15.20 and framework 15.15. I didn’t notice anything in the update that would address this.

    Thanks.



  • I guess I can’t have 2000+ items in a tree used as a menu. It slowed the whole app down. Loading pieces on-demand solved the speed issue, but the tree worked perfectly fine in browsers and Electron, just not Cordova.