quasar 0.15.10 defaults to the v0.14++ starter kit on init?



  • Even though I have freshly installed vue-cli and quasar-cli@latest

    $ quasar version
    
     Quasar CLI v0.6.5
     App running on Quasar v0.15.10
    
    $ node -v
    v9.7.0
    
    $ npm -v
    5.7.1
    
    

    When I init a new project,

    
    $ quasar init test
    $ cd test && npm install
    [...]
    

    The app version is now 0.14.9 and the directory structure is the pre-0.15 type.

    $ quasar version
    
     Quasar CLI v0.6.5
     App running on Quasar v0.14.9
    
    $ ll
    total 16
    -rw-r--r--   1 cwf  staff   240B May  2 00:19 README.md
    drwxr-xr-x  11 cwf  staff   352B May  2 00:19 build
    drwxr-xr-x   5 cwf  staff   160B May  2 00:19 config
    -rw-r--r--   1 cwf  staff   2.0K May  2 00:19 package.json
    drwxr-xr-x  10 cwf  staff   320B May  2 00:19 src
    drwxr-xr-x   5 cwf  staff   160B May  2 00:19 templates
    
    

    The default starter kit template is for v0.14++:

    $ quasar list
    
     Official Quasar App starter kits:
    
      ★ default ($ quasar init default <folder_name>)
        Boilerplate for website (with optional Cordova and Electron wrappers) with Quasar v0.14+
    
    [... other templates, all v14 or older  ...]
    

    I guess the question is, how do I upgrade my starter kit templates? Specifically, the default one.



  • Never mind. Sorry, I asked this exact question a couple months ago and then went to work on something else and forgot. Answer is here: http://forum.quasar-framework.org/topic/1994/installed-0-15-but-init-still-creates-0-14-9-app/4

    (answer, via @vinstah, is nvm install 8 && nvm use 8 && npm i quasar-cli@latest -g && npm i vue-cli -g && quasar init default)