0.15 with rails

  • Hello,

    I’m using 0.14 with rails assets pipeline and got it working fine. I don’t get quasar cli but don’t miss it much, and vue-loader gives me tree shaking, single file components and the like.

    Tried 0.15 and could not get it to work at all. I tried both umd (no tree shaking, and did not work with rails asset pipeline) and direct (no no).

    Any idea or suggestions?

  • The intended way to integrate Quasar into another framework is the UMD version, you would have a really hard time integrating the ESM version, because you need to create the build process by yourself (which totaly is possible, you could take a look at the webpack config Quasar uses) and you can not easily updated.
    The ESM version is intended for SPAs (I count PWAs and ELectron / Cordova as a subset of them). So you would have a standalone Quasar setup and communicate with Rails only via HTTP messages (your Rails app would only be an API).

    There is an example project which integrates Quasar into Laravel, which should be quite similar to Rails, so you may want to take a look at this: https://github.com/neatpro/Laravel-Quasar

Log in to reply