Autocomplete hook beforedestroy issue. HELP

  • I can’t seem to use autocomplete in my component. I always got this error.
    I also made sure that it was imported already in my main.js

  • Are you using quasar-edge?

    I’ve seen a related issue before. Is autocomplete working otherwise?

    This definitely is a bug

  • Admin

    Can you paste the vue component where you are using Autocomplete, please? That error should NOT occur. I’m interested to see details on your use-case. Thanks!

  • @benoitranque No, not using quasar-edge. I’m using 0.14 version. I also tried downgrading to previous versions, still the same… That was my initial thought, but maybe its just an environment issue because I’m using docker. I’m still trying to figure out what’s causing this. For the mean time I’ll just use other ways till new updates come in that might fix the issue, I guess.

  • @rstoenescu
    Sorry for the late reply. I did not have a copy of my initial implementation where i was using a the ‘auto-complete’ component. But I have created a new component which satisfies my initial use case. The error is still the same btw.

            AutoComplete Test
            <q-search inverted color="secondary" v-model="terms" placeholder="Featuring static data">
                :static-data="{field: 'value', list: countries}"
    import countries from '../../../../data/countries.json'
    export default {
      data () {
        return {
          terms: '',

    I have a parent component that has a ‘tab’ component which uses this sub component.

  • Update:
    I can confirm that this issue only occurs in my local (docker) environment. I tried to push the above test component on heroku where my prestaging setup is, and it is working fine. Though I still don’t know what causes the issue locally(docker).

  • Thanks for keeping us updated. Have you tried transferring your code to a new quasar install? That helps, especially if you have updated quasar before

Log in to reply