@dobbel Oh, wait! I see what’s happening. Safari is popping up an additional JSContext inspector for my app every time I click a page or a control. The main inspector for the app gets hidden as a result. All I had to do was to uncheck “Automatically Show Web Inspector for JSContexts” in Safari under Develop > Simulator, and the issue went away. Hopefully this will help someone else who runs into a similar issue at some point in time.