Running 'quasar dev' does nothing? (on freshly installed default starter kit) [solved]



  • Hi,

    I’m trying to create a new app from the default template (0.14), but after doing the init and the npm install, running ‘quasar dev’ does nothing… it just returns to the command line.

    I can run ‘quasar build’, and that works fine, but I can’t get ‘quasar dev’ to do anything. I have it running fine in a different app, though.

    Does anyone have any ideas why this is happening?

    TIA!
    (p.s. I also posted this in the ‘Starter Kit’ forum, because I’m not 100% sure where the best place is to ask the question)



  • Solved!

    The default port 8080 was in use, I changed it to an unused port eg :3000, and it works now.

    Strange, no error message is posted that the port was in use. Just… nothing!


  • Admin

    @A3an hmm, it should tell the port is in use… if you are using latest Quasar CLI.



  • I also had trouble running quasar for the 1st time, using Windows 10.
    command : quasar dev
    Nothing was displayed. http://localhost:8080 got the message “connection rejected”.

    Using command : npm run dev mat
    I figured out I had the error “Error: spawn cmd ENOENT” => Verify that your local variable PATH contains “C:\Windows\System32”, reboot if necessary.
    If it’s still not working, change server port (/config/index.js), as explained above.

    Hope it can help someone.


Log in to reply
 

Looks like your connection to Quasar Framework was lost, please wait while we try to reconnect.