Build error: "TypeError: Cannot read property 'split' of undefined"



  • Hello forum,

    I am setting up a quasar project and am getting the above error message (“TypeError: Cannot read property ‘split’ of undefined”) when running “quasar build mat” on one of my pages which contains a data table (with an Axios request). The rest of the build works as expected.

    Anyone here who has had the same issue or could explain the error to me? Could not find any information on it. I am running Vue 2.3.4 btw, here are my dependencies:

      "dependencies": {
    "axios": "^0.16.2",
    "babel-runtime": "^6.25.0",
    "quasar-extras": "0.x",
    "quasar-framework": "^0.14.1",
    "vue": "~2.3.4",
    "vue-awesome-swiper": "^2.6.2",
    "vue-i18n": "^7.2.0",
    "vue-router": "^2.7.0"
    

    Thank you for any advice on this!

    Arjanski


  • Admin

    Can you copy-paste the full log to see where the error is at, pls?
    Also, can you run the equivalent “npm run build mat” and tell me what you get?

    PS: the template you are using might be at fault, since that is a build error and it doesn’t matter what packages you are using.

    Thanks!



  • Thanks a kit @rstoenescu for your help!

    This is the whole error from my console after running “quasar build mat”:

    `vendor.js:6 TypeError: Cannot read property 'split' of undefined
    at q (vendor.js:6)
    at new Ki (vendor.js:6)
    at Nt (vendor.js:6)
    at Mt (vendor.js:6)
    at s.t._init (vendor.js:6)
    at new s (vendor.js:6)
    at Xt (vendor.js:6)
    at init (vendor.js:6)
    at c (vendor.js:6)
    at l (vendor.js:6)
    $ @ vendor.js:6`
    

    Running “npm build mat” gets me the exact same error.

    Cheers!


  • Admin

    Any chance I can take a look at your repo?


  • Admin

    Also, what node and npm versions are you using?



  • Sure @rstoenescu thanks a lot, I could send you a ZIP with the repo if you provide me with an email address? Or what would you prefer?

    I am using Node v6.9.4 and NPM 3.10.10.



  • I sent you a chat message in here with a WeTransfer link just now


Log in to reply
 

Looks like your connection to Quasar Framework was lost, please wait while we try to reconnect.