Prevent q-toolbar from ever hiding?



  • On ios, when scrolling up, the q-toolbar element will hide (and then show again when scrolling down). Is there a way to prevent this from ever hiding, to keep it always fixed at the top of the view?



  • Could you provide an image or video of that behavior?
    Are you using version 0.14? I suspect, you do not mean the Toolbars, but are referring to the Layout Header.
    The stickiness of the Layout can be set by using the view prop, you can play with it here:
    http://quasar-framework.org/quasar-play/apple/index.html#/showcase/layout/play-with-layout



  • Thanks I mean the toolbar at the top of the layout, yes. On the web, it is sticky (by that I mean it does not disappear when scrolling), but when I create a cordova wrapper for the same build, on my iphone the layout toolbar top disappears when scrolling, which I don’t want. I want the toolbar at the top of the layout to stay always at the top of the screen, always taking the same amount of space.

    0_1503238746003_Screen Shot 2017-08-20 at 10.11.23 AM.png



  • I noticed that if I add the reveal property, the web will get the same behavior I DON’T WANT (which is happening on the iphone all the time)



  • So if you use Chrome Debug and in the responsive tools, set the Device to iOS this does not happen?
    If so, it seems like it is a bug, in which case you should post it to the GitHub repo.



  • Yeah, in chrome tools setting device iphone this does not happen. Only on an actual iphone itself after the Cordova build. I will report it as a bug (but is it a quasar bug or a cordova bug?)



  • Hard to tell, if it is Quasar or Cordova specific.
    Maybe @rstoenescu can have a look on this.



  • @ssuess can you post your layout code? I had similar experience with v0.14 initially setting my view property to the below resolved it.

    <q-layout ref="layout" view="lHh Lpr lFf">
    


  • Sure here it is. Like I said before, works just fine in web browser, but not on iPhone directly.

    <q-layout ref="layout" view="lHh Lpr fff" :left-class="{'bg-grey-2': true}" >



  • Using WKwebview solves this problem.


Log in to reply
 

Looks like your connection to Quasar Framework was lost, please wait while we try to reconnect.