I have just started to v0.14.0 issue in compilation error



  • Hi,
    I am just init v0.14.0 and when i just save code without done any changes to the code got compilation error .
    Please look into this.

    0_1500895327344_helppng.png

    And below my json file that has been created

    {
    “name”: “quasar-app”,
    “version”: “0.0.1”,
    “description”: “A Quasar App”,
    “author”: “Your Name”,
    “scripts”: {
    “clean”: “node build/script.clean.js”,
    “dev”: “node build/script.dev.js”,
    “build”: “node build/script.build.js”,
    “lint”: “eslint --ext .js,.vue src”
    },
    “dependencies”: {
    “babel-runtime”: “^6.0.0”,
    “deps”: “^0.1.2”,
    “quasar-cli”: “^0.6.2”,
    “quasar-extras”: “0.x”,
    “quasar-framework”: “git+https://git@github.com/quasarframework/quasar-edge.git”,
    “vue”: “~2.3.0”,
    “vue-router”: “^2.0.0”
    },
    “devDependencies”: {
    “autoprefixer”: “^6.4.0”,
    “babel-core”: “^6.0.0”,
    “babel-eslint”: “^7.0.0”,
    “babel-loader”: “^7.0.0”,
    “babel-plugin-transform-runtime”: “^6.0.0”,
    “babel-preset-es2015”: “^6.0.0”,
    “babel-preset-stage-2”: “^6.0.0”,
    “colors”: “^1.1.2”,
    “connect-history-api-fallback”: “^1.1.0”,
    “css-loader”: “^0.28.0”,
    “es6-promise”: “^4.1.1”,
    “eslint”: “^3.0.1”,
    “eslint-config-standard”: “^10.2.1”,
    “eslint-friendly-formatter”: “^2.0.5”,
    “eslint-loader”: “^1.3.0”,
    “eslint-plugin-html”: “^2.0.1”,
    “eslint-plugin-import”: “^2.2.0”,
    “eslint-plugin-node”: “^4.2.2”,
    “eslint-plugin-promise”: “^3.3.0”,
    “eslint-plugin-standard”: “^3.0.1”,
    “eventsource-polyfill”: “^0.9.6”,
    “express”: “^4.13.3”,
    “extract-text-webpack-plugin”: “^2.0.0-beta.4”,
    “file-loader”: “^0.11.1”,
    “friendly-errors-webpack-plugin”: “^1.1.3”,
    “html-webpack-plugin”: “^2.8.1”,
    “http-proxy-middleware”: “^0.17.0”,
    “json-loader”: “^0.5.4”,
    “opn”: “^5.0.0”,
    “optimize-css-assets-webpack-plugin”: “^1.3.1”,
    “postcss-loader”: “^1.0.0”,
    “progress-bar-webpack-plugin”: “^1.9.0”,
    “purify-css”: “^1.2.2”,
    “shelljs”: “^0.7.0”,
    “stylus”: “^0.54.5”,
    “stylus-loader”: “^3.0.1”,
    “url-loader”: “^0.5.7”,
    “vue-loader”: “^12.0.2”,
    “vue-style-loader”: “^3.0.1”,
    “vue-template-compiler”: “~2.3.0”,
    “webpack”: “^2.2.1”,
    “webpack-dev-middleware”: “^1.8.4”,
    “webpack-hot-middleware”: “^2.17.0”,
    “webpack-merge”: “^4.0.0”
    }
    }



  • This was solved on gitter, a fresh install following the forum’s guides fixed the issue.



  • @spectrolite , thanks fixed this issue as you suggested in this post (http://forum.quasar-framework.org/topic/522/upgrade-guide-for-0-14-beta)


Log in to reply
 

Looks like your connection to Quasar Framework was lost, please wait while we try to reconnect.