Do not upgrade to Vue 2.4.x (yet)
Vue 2.4 currently has a bug, do not upgrade to it yet.
For more information: https://github.com/quasarframework/quasar/issues/710
According to @murbanowicz, QTab isn’t working either.
And for those out of the loop, the default quasar template has been modified to stick to Vue 2.3.x as of 5986e99, so if you know anyone having an issue with certain components they probably need to downgrade.
Looks like we’re waiting for vuejs/vue#6093 to be resolved.
And now we wait for vue 2.4.2!
Am I correct in understanding that the issue is now resolved, but since it s been committed to dev, it would work only on vuejs edge?
yyx990803 merged commit f41773f into dev 1 day ago
^2.4.2. , and got lots of warnings
[Vue warn]: Injection "__field" not foundand
[Vue warn]: Avoid using non-primitive value as key, use string/number value instead.
If I update
^13.0.2with webpack 3 as well as 2 my app wont start:
[Vue warn]: Failed to mount component: template or render function not defined. found in ---> <Anonymous> <Root>
(Vue 2.4.1) I got that error too: [Vue warn]: Injection “__field” not found and [Vue warn]: Avoid using non-primitive value as key, use string/number value instead.
To revert to vue 2.3.4 (ie. the latest 2.3.x)
- locate the vue folder in your node_modules folder and delete it.
- open your app’s package.json and set the vue version to 2.3.4, excluding major versions, like so:
npm iin your app’s folder
- (optional, but recommended) run
quasar dev, open your app in Chrome and use Vue-tools to check for the currently used Vue.js version.
Tilde (~) means it will NOT automatically get upgraded to the next minor version (eg. the current 2.4.2 which still has a bug preventing quasar from running).
The usual caret (^) meant we would automatically upgrade to minor versions like 2.4.x, 2.5.x etc. up to but excluding the next major versions (3.x.x etc)
Bullet point 4 is also a good way to know which Vue version is really running even before decide to you attempt the fix, since your app’s package.json can be deceiving, and fishing Vue’s package.json file out of node_modules to look for the version is quite annoying.
For info - I had to pin
vue-template-compilerto 2.3.4 as well - without that, I got a version mismatch when running
Working with the Vue guys to solve the
[Vue warn]: Injection “__field” not founderror. That’s last one before Vue 2.4 can be used.
@rstoenescu please keep us informed about this issue . QUasar looks pretty amazing and right now I am testing the v 14.
Thanks @rstoenescu , you save my day!!! We keep watching this topic.
@rstoenescu Any news about this?
Not yet. Waiting for Evan to push the PR…
So, I saw there were new versions of Vue (2.4.3 and 2.4.4 even), so I went ahead and upgraded. But alas, I still have tons of
[Vue warn]: Injection “__field” not founderrors. Any ideas what to do?
I am also getting similar warning when using AutoComplete
[Vue warn]: Injection "__inputParent" not found. Is this related to same Vue issue? If not, I can open another post for help.
[Vue warn]: Injection "__inputParent" not found found in ---> <QAutocomplete> <QInputFrame> <QInput> <QField>
Yes it is. Any injection warning is the same issue.
Thank you for the response. Eagerly waiting for the fix…