q-data-table: responsive columns break when in dist mode though work perfect in 'debug'



  • 0_1497356272950_upload-927ddda7-9d94-4f2a-b84b-390424a1d74a

    When screen size becomes small the q-data-table swaps columns to one column, as in the attached picture.
    This all works great while in debug mode (npm run dev).
    When I run npm run build and use the output from dist. (e.g. run live-server on that folder or deploy it to a real webserver), the responsiveness is gone.
    Any idea what’s going wrong?
    Thanks a lot
    paul;



  • I’m able to reproduce the problem with a brand new quasar app based on latest cli.
    I simply use the standard sample in the brilliant quasar-play app:
    https://github.com/quasarframework/quasar-play/blob/master/src/components/showcase/web-components/data-table.vue

    I run the app with npm run dev and the table is fully responsive. Check.
    I run then npm run build and consume the dist folder with a web server and all responsiveness is gone with wind.

    Please advice if I can help with further help with reproducing the problem.
    Thanks a lot.



  • Although we’d normally chase this problem and solve it for sure, practically every component, including data-table, has been revamped in the 0.14 version, which is due to be released in the next day or two. So, please be patient until the release, and if this problem should still be in v0.14, we’ll tackle it right after the release. And of course, if one of you would also be so nice and create an issue in Github to confirm its existence in 0.14. :smile:

    If you find it solved in 0.14, just a quick note here would be fantastic! :smile:

    Scott



  • Thanks. I proceed per your suggestion. Looking forward to all goodness in 0.14.



  • Same problem here, even after updating to 0.14, responsive when in dev mode and showing like a normal table after build, I published a gist with a demonstration of the bug https://gist.github.com/mvalim/bf96afd7250591be8c07f354d9da567d


Log in to reply
 

Looks like your connection to Quasar Framework was lost, please wait while we try to reconnect.