fix uglifyjs problem



  • Hello,
    I’m using quasar-cli with the quasar-framewwork 0.13.4
    There is a little problem when I launch the command “quasar dev”.
    An error message appears:

    X:\path\to\quasar-app\node_modules\uglifyjs\index.js:1
    (function (exports, require, module, __filename, __dirname) { throw "uglifyjs is deprecated - use uglify-js instead.";
                                                                  ^
    uglifyjs is deprecated - use uglify-js instead.
    

    Looking for a bit, I discovered that it comes from the purify-css librarie.
    It using "uglifyjs": "^2.4.10"

    To fix this i have just rewriting in ./node_modules/purify-css/src/utils/FileUtil.js
    and replace this line…

    var UglifyJS = require('uglifyjs');
    

    …with this one

    var UglifyJS = require('uglify-js');
    

    hope that this could help some in the same case and sorry for my basic english (i’m french)

    :)



  • Salut @remy

    The issue was reported to purify-css maintainer and it was fixed. Simply modify your quasar template following the changes in this commit and update your packages. It works for me :slight_smile:

    Laurent



  • This post is deleted!


  • @LaurentPayot Great !
    Thank you :grin:


Log in to reply
 

Looks like your connection to Quasar Framework was lost, please wait while we try to reconnect.