can't update quasar-cli



  • I’ve tried a lot, but nothing works.
    Running windows 10
    node version: v9.8.0
    npm version: 5.6.0
    vue-cli version: 2.8.2
    everytime I try to run “npm i -g quasar-cli” it seems to work.
    output:
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.1.3 (node_modules\quasar-cli\node_modules\fsevents):
    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.1.3: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“win32”,“arch”:“x64”})

    • quasar-cli@0.15.12

    if I do “quasar version”:
    Quasar CLI v0.6.4
    Update available 0.6.4 → 0.15.12 │
    Run npm i -g quasar-cli to update

    I deleted all appData/Roaming/npm and appData/Roaming/npm-cache. For my user and for admin-user. But my console recognize quasar as a command! Why? I’ve totally removed it and restarted the machine!!

    On another machine I’ve installed a starter-Kit for Quasar and everything works fine if I do “quasar dev”.
    On this machine if I type “quasar dev” for the same starter-kit: npm ERR! missing script: dev and the “update available” message.

    Please help!
    thx
    ©a-x-i



  • delete your complete node installation and remove the node_modules folder and the package-lock file in your project!

    then install the latest LTS version of node for windows: https://nodejs.org/en/

    then do fresh install of npm -i g quasar-cli . and run npm install in your project.

    cheers max



  • Thank you max, that did the trick.
    I didn’t want to completely remove node because of another app. I thought this would have some sideeffects. But the app runs properly!
    Thank you again for you help!
    greets from Tyrol (Austria)
    ©a-x-i


Log in to reply
 

Looks like your connection to Quasar Framework was lost, please wait while we try to reconnect.