installed 0.15 but init still creates 0.14.9 app?

  • I’ve got a quasar app created with 0.14.9 and I’d like to move it to 0.15 (.11, I guess, currently). But when I try to upgrade quasar-cli and init a new project, I still get a 0.14.9 installation

    $ npm install -g quasar-cli@latest
    + quasar-cli@0.15.11
    removed 15 packages, updated 40 packages and moved 1 package in 24.816s
    $ quasar init quasar-zep-15
    $ cd quasar-zep-15
    $ npm install
    $ quasar version
     Quasar CLI v0.6.5
     App running on Quasar v0.14.9

    I’ve read the upgrade guide, but can’t figure out what I’m doing wrong. I suspect I’m suffering under some misunderstanding about the relationship between quasar, quasar-cli, and quasar-framework (which is versioned at 0.14.9 in package.json whether I manually install it with --save or not)

  • Admin


    Try closing your terminal and opening it again. Somehow you’re still using the old Quasar CLI version.
    If it still doesn’t works, then npm uninstall -g quasar-cli then npm install -g quasar-cli again.

  • Hm., thanks. Neither of these worked. I took a while to reply while I ripped out quasar, vue, and other dependencies and re-installed them but I still get the results between the backticks above. npm list -g gives me

    ├─┬ quasar@0.0.18
    │ ├─┬ earlgrey-runtime@0.1.0
    │ │ ├── core-js@2.5.3
    │ │ ├── kaiser@0.0.4 deduped
    │ │ ├── lodash@4.17.5
    │ │ └── regenerator-runtime@0.9.6
    │ └─┬ kaiser@0.0.4
    │   └── earlgrey-runtime@0.1.0 deduped
    ├─┬ quasar-cli@0.15.11
    [lots of stuff here ...]
    ├── quasar-framework@0.15.7
    ├── vue@2.5.16
    └─┬ vue-cli@2.9.3
    [lots of stuff here....]

    but I still get App running on Quasar v0.14.9 after an quasar init and an npm install and a quasar version. I don’t have a question yet.

  • I had the same problem until I updated my node version. with nvm. nvm install 8 && nvm use 8 && npm i quasar-cli@latest -g && npm i vue-cli -g && quasar init default

  • I created a new user and installed node and the applicable npm packages from scratch and it worked fine. So maybe a versioning problem indeed. So I went back and followed vinstah’s advice to use nvm and voila, it worked. Thanks!

Log in to reply

Looks like your connection to Quasar Framework was lost, please wait while we try to reconnect.