build error



  • i have installed quasar starter kit… then i run quasar build command and the terminal show me this error:

    var/www/html/pmt/client/node_modules/webpack/lib/ProgressPlugin.js:121
    compiler.hooks.compilation.tap(“ProgressPlugin”, compilation => {
    ^

    TypeError: Cannot read property ‘compilation’ of undefined

    • ProgressPlugin.js:121 ProgressPlugin.apply
      [client]/[webpack]/lib/ProgressPlugin.js:121:19

    • Tapable.js:375 Compiler.apply
      [client]/[quasar-cli]/[tapable]/lib/Tapable.js:375:16

    • webpack.js:33 webpack
      [client]/[quasar-cli]/[webpack]/lib/webpack.js:33:19

    • quasar-build:109 Object.<anonymous>
      [client]/[quasar-cli]/bin/quasar-build:109:1

    • module.js:11 require
      internal/module.js:11:18

    • quasar:80 Object.<anonymous>
      [client]/[quasar-cli]/bin/quasar:80:3

    when i installed webpack also i get this warnings (which maybe is the cause):

    npm WARN extract-text-webpack-plugin@3.0.2 requires a peer of webpack@^3.1.0 but none is installed. You must install peer dependencies yourself.
    npm WARN html-webpack-plugin@2.30.1 requires a peer of webpack@1 || ^2 || ^2.1.0-beta || ^2.2.0-rc || ^3 but none is installed. You must install peer dependencies yourself.
    npm WARN sw-precache-webpack-plugin@0.11.4 requires a peer of webpack@^1 || ^2 || ^2.1.0-beta || ^2.2.0-beta || ^3 but none is installed. You must install peer dependencies yourself.
    npm WARN webpack-dev-middleware@1.12.2 requires a peer of webpack@^1.0.0 || ^2.0.0 || ^3.0.0 but none is installed. You must install peer dependencies yourself.
    npm WARN webpack-dev-server@2.11.1 requires a peer of webpack@^2.2.0 || ^3.0.0 but none is installed. You must install peer dependencies yourself.
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.1.3 (node_modules/fsevents):
    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.1.3: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“linux”,“arch”:“x64”})

    does any one can help me please to know what should i do?
    thanks.

    i am using ubuntu 16.04 lts and i have installed node v9.6.1



  • i realize that quasar-cli was not the lasted version, so i updated and now this is the error i get when i try the build command:

    Error: webpack.optimize.CommonsChunkPlugin has been removed, please use config.optimization.splitChunks instead.

    • webpack.js:162 Object.get [as CommonsChunkPlugin]
      [client]/[webpack]/lib/webpack.js:162:10

    • webpack-config.js:295 module.exports
      [client]/[quasar-cli]/lib/build/webpack-config.js:295:28

    • quasar-config.js:380 QuasarConfig.compile
      [client]/[quasar-cli]/lib/quasar-config.js:380:25

    • quasar-build:90 Object.<anonymous>
      [client]/[quasar-cli]/bin/quasar-build:90:14

    • module.js:11 require
      internal/module.js:11:18

    • quasar:80 Object.<anonymous>
      [client]/[quasar-cli]/bin/quasar:80:3


  • Admin

    What’s your package.json? Seems like you are running webpack 4, which shouldn’t even be specified there in the first place.



  • @rstoenescu thanks, i just removed the project and follow quasar doc and now it works…
    thanks again.


Log in to reply
 

Looks like your connection to Quasar Framework was lost, please wait while we try to reconnect.