.15.x init creates no dependencies, is that correct?

  • I am in the process of upgrading .14 to .15 I did an init in a new repo in order to start migrating my source but I see the cli did not create a single dependency in package.json. That can’t be right?? Shouldn’t it at least put Vue and quasar framework as dependencies as before?

      "dependencies": {},
      "devDependencies": {
        "babel-eslint": "8.2.1",
        "eslint": "4.15.0",
        "eslint-config-standard": "10.2.1",
        "eslint-friendly-formatter": "3.0.0",
        "eslint-loader": "1.7.1",
        "eslint-plugin-import": "2.7.0",
        "eslint-plugin-node": "5.2.0",
        "eslint-plugin-promise": "3.4.0",
        "eslint-plugin-standard": "3.0.1",
        "eslint-plugin-vue": "4.0.0",
        "quasar-cli": "^0.15.6"

  • Admin

    This is correct. Everything is handled by the locally installed quasar-cli package.

  • so what dependencies does the cli manage? Vue obviously, what else? Is there a way to list them and their version number?

    Normally I’d upgrade my dependencies as I see fit…so now upgrading any of these can only be done when the cli upgrades?

Log in to reply

Looks like your connection to Quasar Framework was lost, please wait while we try to reconnect.