PWA not running in standalone (Quasar 0.15.2) ?



  • Hy master, How to make PWA running in standalone? I just tried build simple application with Quasar v0.15.2 (starter-kit) with PWA, I have been uploaded to server with https, but when I try to add homescreen, and then running the application, I got application not running in standalone but open in chrome, (Service Worker and Manifest use default), thank you …


  • Admin

    Hi, You either use Quasar starter kit or you go with the UMD version and build a PWA yourself.



  • I use Quasar Starter Kit master.


  • Admin

    Have you read docs? Do you know how PWA works? Might be worth it to read up on that first.



  • Is it possible to install a PWA in dev mode on my smartphone in using the default install banner ?

    I don’t know which requirements I am missing…

    • manifest : default (I suppose it is ok, thanks for generating default fields short_name, icons and start_url fields)
    • https ok (from the quasar.conf.js)
    • default service worker (I suppose it is ok as well)
    • using “quasar dev -m pwa” and visiting several times “https://192.168…:8080” with at least 5 mn of waiting between two visites : ok -> should I use the port 80/443 ?

    Regards


  • Admin

    Check this for “Add to home screen” to speed things up. Otherwise, as far as I know, you need to visit the same URL for a certain number of days in order for the install banner to be triggered: https://www.youtube.com/watch?time_continue=7&v=xkme8WFyoXw
    There’s an equivalent easy way to do on iOS too. Just google for it.



  • Hi, same here.

    • quasar init test (with default settings)
    • quasar build -m pwa -t mat
    • serve /dist directory over HTTPS with a valid certificate
    • “add to home screen” is showing, service worker registered, but it always opens in a new browser tab (display=standalone)

    (quasar-cli 0.15.11 / quasar-framework 0.15.7)

    Regards



  • Stil same problem … 😞


  • Admin

    It depends on the iOS and Android support for PWA. For example, iOS does not have full support (yet). What you are experiencing is not due to Quasar, which I can strongly confirm it does all things correctly.



  • @rstoenescu I tested it with Android 6.0 and Chrome 64/65 using Quasar 0.15 and 0.14 and it does not open in standalone/fullscreen mode.

    However, other PWA’s open in standalone/fullscreen mode. For example: https://airhorner.com/

    Steps:

    • new blank project with default settings (quasar init test)
    • serve /dist/pwa-mat directory over HTTPS with a valid certificate
    • “add to home screen” is showing
    • service worker registered
    • no errors logged in console

    Any clue about how to debug the problem?

    Best regards.


Log in to reply
 

Looks like your connection to Quasar Framework was lost, please wait while we try to reconnect.