Nuxt start kit rc11



  • Problem

    Nuxt start kit has a problem to render the slot components.

    Reason

    Quasar 0.15 use the injection with default value in the components and according to vue documention:

    In 2.5.0+ injections can be optional with default value:

    And nuxt rc11 use vue 2.4.4.

    Alternatives

    1. Inside quasar.ems.js change the components
     Inject : ['layout'] 
    

    Works nice but …i’ll not change the all components.

    1. Run npm i nuxt@next --save beacause this branch use vue .5.3.0+ but dosen’t work for other reasons.

    Someone can help in this case.



  • Nuxt starter kit is marked as WIP(work in progress) and not ready for use. If you try to use it you will run into issues



  • Any idea when it will be ready to use?



  • As soon as 0.15 is out, Raz will get working on 1.0 which will have this feature. I’d say around March?



  • Ok, i’d really would like to use Quasar with Nuxt. Is there anyway to manually incorporate Quasar into Nuxt just to get i running with some basic stuff until the release?

    I have a project that i will finish soon and i’d hate to have to use Vuetify or anything else over Quasar.



  • V0.15 will be out january. It includes a umd version, so it is as simple as adding the file to your index.html



  • Sounds great, thank you so much.


Log in to reply
 

Looks like your connection to Quasar Framework was lost, please wait while we try to reconnect.