Cordova using old builds?

  • scratching my head over here. tried quasar clean, cleaning cordova project etc, every time iOS app launches its an old version with pieces of code that dont exist anymore. any ideas?

  • quasar clean seemed to work, but im confused why that was needed. When i rebuilt cordova wasn’t pulling the new build from dist

  • Admin

    Cordova will bundle the contents of dist folder. The cordova/www folder is actually a symbolic link pointing to /dist. That’s why you have to make sure you build your app (with the theme of your desire) before using Cordova (each time you make a change to your source code).
    Please note that there is a difference between building an app (which also cleans previous builds) and running the dev server. Running dev server does not touches the dist folder. Did I understand correctly your problem?

  • Yeah, but that’s not the issue.

    I’m actually having it again.

    I go into XCode and clean the project

    I type quasar clean

    I type quasar build

    then I go into XCode and rebuild the project and run it on the emulator

    What runs isn’t right / up to date

    I’ve even manually deleted the dist folder and rebuilt.

    Is something being retained somewhere?

  • Admin

    Nope. Nothing retained. What OS are you on?

  • Mac OS X

    If I quasar dev its most definitely the right build

    If I build with Cordova its not

    I’ll do some more tests today

  • cordova prepare is what i was missing

  • Admin

    I usually issue “cordova run” which also installs it on the phone/tablet.

  • That didnt seem to be working, im just running cordova prepare for now before i run.

  • Admin

    Hmm, maybe they changed Cordova’s behavior in later releases. Which version are you using?

Log in to reply

Looks like your connection to Quasar Framework was lost, please wait while we try to reconnect.